Page Serving outage
Incident Report for Leadpages
Resolved
Page serving has returned to normal levels and we're calling this resolved. Thank you for your patience while we worked to resolve this issue.
Posted May 06, 2023 - 01:57 CDT
Monitoring
We are still actively monitoring and working towards a resolution for this issue. We'll have more updates as things progress. Thank you for your patience.
Posted May 06, 2023 - 00:25 CDT
Identified
We are currently experiencing issues which affect our ability to display lists of created assets in accounts or serve published assets. We will provide updates as they become available.
Posted May 05, 2023 - 22:21 CDT
This incident affected: Sites, Published sites, Landing pages, and Published landing pages.