Trouble processing payments.
Incident Report for Leadpages
Resolved
We're happy to report the billing related issues have been resolved.

Thank you for your patience and if you have any questions, please reach out to support@leadpages.com
Posted Sep 13, 2022 - 13:05 CDT
Investigating
We are currently investigating billing related issues. This affects both changing plans and purchasing new subscriptions. We are working with our partners to resolve this as quickly as possible. We’ll provide updates as they become available.
Posted Sep 13, 2022 - 12:46 CDT
This incident affected: User Registration.