Live Support Chat Offline
Incident Report for Leadpages
Resolved
The issue with our live chat has been resolved and chat is available again.
Posted Sep 05, 2023 - 14:40 CDT
Identified
We have updates from our chat provider that they are working to restore live chat. In the meantime, please reach out to us at support@leadpages.com for any support questions.
Posted Sep 05, 2023 - 11:37 CDT
Investigating
Our live support chat has gone offline and we're currently looking into a resolution with our chat provider. Please reach out to us at support@leadpages.com for any support questions. We'll provide updates here as soon as we have them.
Posted Sep 05, 2023 - 10:19 CDT
This incident affected: Support Systems.