Issue with serving pages
Incident Report for Leadpages
Resolved
We've resolved the issue with our page serving platform and all published pages and sites should be available. Thank you for your patience while we worked to resolve this.
Posted Dec 09, 2023 - 11:09 CST
Investigating
We are currently experiencing an issue with our page serving platform, which affects our ability to display published assets. We are working to mitigate the issue as quickly as possible.

We will provide more updates as they are available.
Posted Dec 09, 2023 - 10:23 CST
This incident affected: Published sites and Published landing pages.