Issue displaying leads in the Leads Library
Incident Report for Leadpages
Resolved
We've seen no reoccurrence of the issue in a number of hours so we are calling this resolved. Thank you for your patience and if you have any issues or questions, please reach out to support@leadpages.com
Posted Dec 22, 2023 - 22:33 CST
Monitoring
We are seeing the leads library return to normal. We will continue to monitor the situation and we'll update again once we're sure it's resolved fully.
Posted Dec 22, 2023 - 18:20 CST
Update
We're continuing work to fully identify the issue and apply a fix. Thank you for your patience.
Posted Dec 22, 2023 - 16:15 CST
Investigating
We're currently having intermittent issues with showing our leads library. This currently only affects displaying the lead information and leads are still being captured. Alternatively, downloading your leads directly in the builder also still works. We appreciate your patience while we work to resolve this.
Posted Dec 22, 2023 - 12:54 CST