Issues with published pages and sites loading
Incident Report for Leadpages
Resolved
Thank you for your patience. We're confident the issue has now been resolved. We will continue monitoring but we'll considering this resolved at this time. Please reach out to our support at support@leadpages.com if you have any questions or concerns!
Posted Apr 07, 2023 - 10:52 CDT
Identified
We're currently investigating intermittent issues with published pages and sites not appearing and experiencing slow loading. We're working on mitigation steps currently and we will update once we have confidence the issue is fully resolved. Thank you again for your patience.
Posted Apr 07, 2023 - 09:55 CDT
This incident affected: Published sites and Published landing pages.