Intermittent Publishing Issues
Incident Report for Leadpages
Resolved
Our monitoring shows we can confidently call the issue resolved. Thank you for your patience and if you have any questions, please reach out to support@leadpages.com
Posted Oct 13, 2021 - 16:40 CDT
Investigating
We are aware of an issue that is intermittently slowing our builders ability to duplicate or update existing pages, and is increasing publishing times. Published assets will continue to function, and leads will still be collected during this time.

We are investigating this issue and will provide updates as they become available.
Posted Oct 13, 2021 - 15:17 CDT
This incident affected: Sites and Landing pages.