Issues with Phone Support
Incident Report for Leadpages
Resolved
We've identified and resolved our issue with our phone support. Thank you for your patience while we resolved the issue.
Posted Aug 04, 2021 - 16:56 CDT
Identified
We are currently having an issue with our Phone Support for Advanced customers. We are working with our phone support provider to resolve the issue. In the meantime, please do not hesitate to reach out to our chat or email support located within your account. We will provide updates as they come in.
Posted Aug 04, 2021 - 12:03 CDT
This incident affected: Support Systems.