Slow page loading
Incident Report for Leadpages
Resolved
We're happy to report this issue is now resolved. Thank you for your patience and understanding while we worked to resolve this.
Posted May 22, 2023 - 08:30 CDT
Update
We are continuing our mitigation which has kept things stable for most of the day. However, the issue is not fully resolved and may continue through the night. We expect performance to stay at current levels until we fully resolve the issue. We will provide updates tomorrow (May 22) or if we fully resolve before then. Thank you for your patience.
Posted May 21, 2023 - 21:47 CDT
Identified
We are aware of an issue that is currently causing pages to load slowly. Mitigation efforts are underway and you may experience slow page loading until that mitigation is applied. We will provide another update upon completion of our mitigation.
Posted May 21, 2023 - 10:41 CDT
This incident affected: Published sites and Published landing pages.