Issues with account creation and billing
Incident Report for Leadpages
Resolved
Our partner has applied a fix to the issue and we are considering this resolved. We apologize for any inconvenience!
Posted Sep 16, 2020 - 12:20 CDT
Identified
We're currently experiencing problems with creating new accounts, in-app purchases and managing your plans and billing. We are investigating the issue with our billing partner and will update with more information as details become clarified. You can also view their status page here: https://status.braintreepayments.com/ Thank you for your patience.
Posted Sep 16, 2020 - 11:26 CDT
This incident affected: User Registration.